Nexus 1000V VEM Status Other


We recently discovered that our working Nexus 1000V deployment had stopped working. The vem modules had went into an unknown state. SVS neighbors were seen, SVS Connect to VCenter was working.

nexux1000v(config)# sh mod Mod Ports Module-Type Model Status --- ----- -------------------------------- ------------------ ------------xf 1 0 Virtual Supervisor Module Nexus1000V ha-standby 2 0 Virtual Supervisor Module Nexus1000V active * 3 332 Virtual Ethernet Module NA other 4 332 Virtual Ethernet Module NA other

I started at the top of the configuration and started removing non-critical pieces. The network-segment-manager had caused the vems to go into an unknown state. After removing it you can see they came back online immediately.

nexux1000v(config)# no feature network-segmentation-manager nexux1000v(config)# 2014 Sep 3 01:27:51 nsn-hq-dsw-01 %VEM_MGR-2-VEM_MGR_DETECTED: Host nsnucs02 detected as module 4 2014 Sep 3 01:27:51 nexux1000v %VDC_MGR-2-VDC_CRITICAL: vdc_mgr has hit a critical error: SPROM data is invalid. Please reprogram your SPROM! 2014 Sep 3 01:27:51 nexux1000v %VEM_MGR-2-MOD_ONLINE: Module 4 is online 2014 Sep 3 01:27:53 nexux1000v %VEM_MGR-2-VEM_MGR_DETECTED: Host nsnhqucs01 detected as module 3 2014 Sep 3 01:27:53 nexux1000v %VDC_MGR-2-VDC_CRITICAL: vdc_mgr has hit a critical error: SPROM data is invalid. Please reprogram your SPROM! 2014 Sep 3 01:27:53 nexux1000v %VEM_MGR-2-MOD_ONLINE: Module 3 is online

nexux1000v(config)# sh mod Mod Ports Module-Type Model Status --- ----- -------------------------------- ------------------ ------------ 1 0 Virtual Supervisor Module Nexus1000V ha-standby 2 0 Virtual Supervisor Module Nexus1000V active * 3 332 Virtual Ethernet Module NA ok 4 332 Virtual Ethernet Module NA ok


32 views